Email Analytics service disruption
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted 5 days ago. Oct 09, 2019 - 21:07 EDT
Investigating
We are currently investigating this issue.
Posted 5 days ago. Oct 09, 2019 - 20:49 EDT
This incident affected: Email Analytics.