Litmus Application
Incident Report for Litmus
Resolved
This issue is now resolved. Thank you for your patience!
Posted 4 months ago. Aug 10, 2018 - 12:54 EDT
Investigating
We are currently investigating an issue where users cannot login or use the Litmus application. We will update this page as soon as we have more information or have a fix. Thank you for your patience!
Posted 4 months ago. Aug 10, 2018 - 12:02 EDT
This incident affected: Litmus Application.