Webmail testing
Incident Report for Litmus
Resolved
Webmails should all now be available!
Posted about 1 year ago. Nov 11, 2016 - 09:08 EST
Identified
Due to internal network issues, our webmail testing is currently down. We are working on a fix and will update this status when we have one in place.
Posted about 1 year ago. Nov 10, 2016 - 13:49 EST