Windows 10 Mail upgrades
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted 22 days ago. Oct 23, 2018 - 14:05 EDT
Investigating
Customers may notice delayed results from Windows 10 Mail email previews while we upgrade our infrastructure. Windows 10 Mail previews performance will return to normal on October 17th.
Posted about 1 month ago. Oct 15, 2018 - 14:24 EDT
This incident affected: Email Previews (Windows 10 Mail (Windows 10)).