Outlook, Office 365, and Yahoo! Webmail accounts not generating Email Previews
Incident Report for Litmus
Resolved
We are back! Thank you for your patience.
Posted Aug 27, 2016 - 11:45 EDT
Investigating
We are aware of the issue and are working on getting them back up as quickly as we can. We will update you as soon as the issue is resolved.

Thanks!
Posted Aug 25, 2016 - 14:46 EDT