Payment processor outage
Incident Report for Litmus
Resolved
We have been informed by our payment processor that this incident is now resolved. All billing and invoice functionality should be working as normal.
Posted Aug 02, 2022 - 12:27 EDT
Identified
Our third-party payment processor is experiencing an outage, which is affecting the Litmus sign-up page, as well as billing and invoice pages within the app. Thank you for your patience!
Posted Aug 02, 2022 - 10:12 EDT