Litmus Builder Unresponsive
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted about 1 month ago. Mar 20, 2017 - 15:57 EDT
Identified
We are aware of an issue that is affecting Litmus Builder. We are already working on a solution and it should be back up shortly. Thanks!
Posted about 1 month ago. Mar 20, 2017 - 15:22 EDT