Checklist Emails Currently Down
Incident Report for Litmus
Resolved
Emails are once again coming through. Any messages sent that were not received will need to be re-sent. We apologize for the inconvenience.
Posted 10 months ago. Mar 16, 2018 - 14:16 EDT
Investigating
At this time, emails sent to Litmus test addresses are not processing. We are currently investigating this issue, and will update shortly.
Posted 10 months ago. Mar 16, 2018 - 14:12 EDT