Email Previews are not returning results
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 05, 2019 - 10:37 EDT
Investigating
We are currently aware of the issue and are working to get things back up. We will update this page once everything is back up and running.
Posted 4 months ago. Jun 05, 2019 - 09:41 EDT
This incident affected: Litmus Application.