Outlook 2019 Previews unavailable
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted 9 months ago. Jan 02, 2019 - 16:31 EST
Investigating
We are currently experiencing an outage for Previews for Outlook 2019 due to configuration issues. We hope to have this resolved soon.
Posted 9 months ago. Jan 02, 2019 - 09:10 EST
This incident affected: Email Previews (Outlook 2019 (Windows 10)).