Legacy Emails view unavailable
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted Nov 14, 2024 - 03:44 EST
Investigating
Following database maintenance we're investigating a performance regression that's made this feature unusable.
Posted Nov 14, 2024 - 00:26 EST
This incident affected: Litmus Application.