Link Check Tool - Unresponsive
Incident Report for Litmus
Resolved
Thank you for your patience. The Link Check Tool is now operational
Posted Mar 13, 2015 - 14:41 EDT
Investigating
We are looking into an issue where the Link Check Tool becomes unresponsive to submitted Link Check tests.
Posted Mar 13, 2015 - 10:38 EDT