Email Previews - Error when returning tests
Incident Report for Litmus
Resolved
Thank you for your patience.
Posted Feb 13, 2015 - 15:01 EST
Investigating
We are experiencing an issue when returning Email Previews tests. If you receive a failure please retry your test. We are working on resolving the issue as quickly as possible. Thank you for your patience.
Posted Feb 13, 2015 - 14:53 EST