Windows 10 Mail Previews are temporarily unavailable
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted about 2 months ago. Aug 16, 2019 - 10:24 EDT
Identified
Email Previews in Windows 10 Mail are temporarily experiencing some issues. We're working to bring them back on line as soon as possible.
Posted 2 months ago. Aug 08, 2019 - 17:09 EDT
This incident affected: Email Previews (Windows 10 Mail (Windows 10)).