Spam Tests: Barracuda Test Results are not returning scores
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted 10 months ago. May 01, 2017 - 16:22 EDT
Investigating
We are aware of this issue and are working with the service provider to get it resolved as quickly as we can.

Thanks!
Posted 10 months ago. May 01, 2017 - 13:50 EDT