We are currently investigating an outage with our billing provider.
Incident Report for Litmus
Resolved
Connectivity has been restored at our billing provider. We will continue to monitor.
Posted 10 months ago. Feb 01, 2017 - 11:08 EST
Investigating
We are currently investigating this issue.
Posted 10 months ago. Feb 01, 2017 - 10:43 EST