Email Analytics, Page Testing, and other services affected by Amazon AWS outtage
Incident Report for Litmus
Resolved
All issues pertaining to the AWS outage have been resolved. Thank you for your patience!
Posted Sep 22, 2015 - 17:39 EDT
Investigating
Some customers may experience some delays when trying to submit Page Tests, retrieve Email Analytics data, or navigate other areas of the Litmus app due to an Amazon Web Services outtage. Amazon is keeping us up-to-date and we'll keep you updated as we get more information. Thanks for your patience!
Posted Sep 21, 2015 - 17:35 EDT