Service Downtime
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted 18 days ago. Jun 07, 2017 - 12:36 EDT
Identified
We are aware of an issue causing downtime on the site. A fix is in the works and will be put in place shortly.
Posted 18 days ago. Jun 07, 2017 - 12:28 EDT