Litmus app experiencing some slowness
Incident Report for Litmus
Resolved
We are back! Thanks!
Posted Oct 27, 2015 - 18:22 EDT
Identified
We've identified an issue that might create some intermittent slowness. We're on the case. We'll get Litmus back to our normal fast speed as quickly as we can. Thanks!
Posted Oct 27, 2015 - 14:59 EDT