Unable to send emails from Putsmail
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted Nov 26, 2024 - 12:09 EST
Investigating
We are currently investigating an issue with sending emails from Putsmail.
Posted Nov 26, 2024 - 10:25 EST
This incident affected: Labs (PutsMail).