Checklists Failure
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 26, 2018 - 17:21 EDT
Investigating
We are currently investigating an issue involving failure to complete some Checklist tests.
Posted 3 months ago. Jul 26, 2018 - 15:49 EDT
This incident affected: Litmus Application.