Litmus Chrome Extension down
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted 3 months ago. Feb 26, 2019 - 14:31 EST
Investigating
We are currently investigating this issue.
Posted 3 months ago. Feb 26, 2019 - 13:00 EST