Barracuda Score Filter Results
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted Sep 29, 2023 - 11:58 EDT
Investigating
We are currently investigating an issue affecting Barracuda score filter results.
Posted Sep 05, 2023 - 17:47 EDT
This incident affected: Spam Filters (Score Filters).