Unable to process payments
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted 7 months ago. Jan 03, 2019 - 16:54 EST
Investigating
We are unable to process payments for upgrades, renewals, and new account signups at this time due to connectivity issues with our payment processing partners. We will update this issue as soon as this issue has been resolved. Thank you for your patience.
Posted 7 months ago. Jan 03, 2019 - 13:45 EST