Incoming email tests are delayed

Incident Report for Litmus

Resolved

This issue has been resolved. If you have not received your Litmus test already, please resend your email using your Litmus test address.
Posted Apr 24, 2025 - 12:22 EDT

Investigating

We are currently investigating an issue where emails sent to your Litmus test address are delayed/not arriving.
Posted Apr 24, 2025 - 11:36 EDT
This incident affected: Litmus Application.