Email Previews - Taking longer than usual to create and finish tests
Incident Report for Litmus
Resolved
We are back up and running normally. Thank you for your patience.
Posted Apr 13, 2015 - 12:42 EDT
Investigating
We're looking into why Email Previews are taking so long to start and finish. We hope to have things situated soon. This is our top priority.
Posted Apr 13, 2015 - 10:12 EDT