Slow Loading Builder Results
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted Oct 03, 2020 - 21:18 EDT
Identified
We are aware of an issue where Builder Email Previews are not returning as quickly as normal. We are actively working on this issue and will update this page once the issue is resolved. Thanks!
Posted Oct 03, 2020 - 19:44 EDT
This incident affected: Litmus Application.