Payment Processor Outage
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted Apr 17, 2023 - 12:02 EDT
Monitoring
Our third-party payment processor seems to be experiencing an outage which is affecting the Litmus sign-up page, as well as billing and invoice pages within the app. Thank you for your patience!
Posted Apr 17, 2023 - 11:25 EDT
This incident affected: Litmus Application.