Sending email to Litmus test addresses may not create new tests
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted about 1 month ago. Sep 09, 2019 - 11:24 EDT
Identified
We have identified the issue and are working on a fix. We should be back up-and-running soon!
Posted about 1 month ago. Sep 09, 2019 - 09:50 EDT
This incident affected: Litmus Application.