Email Previews - Outlook Desktop Clients failing a high percentage of tests
Incident Report for Litmus
Resolved
Thank you for your patience. We have identified the cause and have implemented a fix. Outlook Desktop Clients are functioning normally.
Posted Mar 23, 2015 - 14:35 EDT
Investigating
We are currently investigating an issue where our Outlook Desktop Clients are experiencing an unusually high failure rate. We are close to identifying the cause of this issue. Thank you for your patience as we work to bring these clients back.
Posted Mar 23, 2015 - 13:19 EDT