Orange.FR Previews unavailable
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted 15 days ago. Oct 30, 2018 - 09:03 EDT
Investigating
We are currently working to restore Orange.FR webmail previews which are currently unavailable.
Posted 16 days ago. Oct 29, 2018 - 17:23 EDT
This incident affected: Email Previews (Orange.fr (Explorer), Orange.fr (Chrome), Orange.fr (Firefox)).