Issues with new Litmus account sign-ups
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 22, 2019 - 13:16 EDT
Investigating
We are aware of an issue affecting users who are trying to sign up for Litmus accounts. We are currently working on it and hope to have this resolved soon. Thanks!
Posted 3 months ago. Jul 22, 2019 - 13:07 EDT