Delay in receiving test results
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted Feb 10, 2015 - 13:28 EST
Identified
We have identified an issue that is causing some delay in receiving test results. We are working on this issue and expect it to be resolved shortly.
Posted Feb 10, 2015 - 11:55 EST