Email Analytics - Individual Hits returning slowly
Incident Report for Litmus
Resolved
All Email Analytics data should be returning normally now. Thank you for your patience.
Posted Feb 20, 2015 - 11:48 EST
Investigating
We are experiencing large volumes of Email Analyitics results being sent and received. You may experience delays in receiving your campaign data. We are working on resolving the issue right now.
Posted Feb 20, 2015 - 10:27 EST