Litmus App Inaccessible
Incident Report for Litmus
Resolved
The Litmus application is now accessible again. We apologize for any inconvenience this might have caused.
Posted 11 months ago. Jan 09, 2017 - 13:42 EST
Identified
We are currently working to resolve an issue that is preventing users from accessing the Litmus application.
Posted 11 months ago. Jan 09, 2017 - 13:15 EST