Litmus Email Previews Clients Unresponsive
Incident Report for Litmus
Resolved
We are back! Thank you for your patience!
Posted Aug 17, 2015 - 15:35 EDT
Investigating
We are currently investigating an issue that is causing some of our Email Previews clients to become unresponsive. We're on top of it and we hope to have everything back up shortly.
Posted Aug 17, 2015 - 10:17 EDT