Freenet.de previews testing incident
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted 12 months ago. Nov 24, 2016 - 15:26 EST
Investigating
At this time Freenet.de previews may not be available for Internet Explorer or Chrome. We are working on a fix and will update the incident when we have more information.
Posted 12 months ago. Nov 24, 2016 - 11:05 EST