Yahoo! Mail outage
Incident Report for Litmus
Resolved
Yahoo! Mail seems to be having intermittent issues across the globe, but we are now processing Email Previews for our Yahoo! accounts.
Posted Nov 11, 2015 - 16:36 EST
Investigating
Yahoo! Mail is experiencing an outage at the moment. This is affecting our Yahoo! Mail accounts and Email Previews. We will update this page once everything is back online. Thanks!
Posted Nov 11, 2015 - 15:38 EST