Spam Testing - delayed
Incident Report for Litmus
Resolved
Thank you for your patience.
Posted Mar 02, 2015 - 11:24 EST
Investigating
We are aware that our Spam testing service is experiencing heavy delays. We are currently working on a resolution. Thank you for your patience.
Posted Mar 02, 2015 - 11:04 EST