Outlook 2010 - Outtage
Incident Report for Litmus
Resolved
This issue has been resolved. Thank you for your patience.
Posted Feb 17, 2015 - 15:40 EST
Identified
We are aware of an issue that is causing Outlook 2010 Email Previews to fail. We are working on implementing a fix. Thank you for your patience.
Posted Feb 17, 2015 - 12:10 EST