Slow Processing of Spam Blacklist Tests
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted 12 months ago. Sep 26, 2017 - 12:29 EDT
Investigating
We are currently investigating Spam blacklist tests that are processing slowly and occasionally failing to complete.
Posted 12 months ago. Sep 26, 2017 - 11:29 EDT