Email Previews: Yahoo! Clients experiencing periodic downtime
Incident Report for Litmus
Resolved
Thank you for your patience!
Posted 6 months ago. Apr 10, 2017 - 12:06 EDT
Investigating
We are aware of a situation that is causing our Yahoo! webmail clients to have extended periods of downtime. We are working on a permanent fix for this.

Thank you for your patience!
Posted 6 months ago. Apr 06, 2017 - 11:43 EDT