OL2019 temporarily unavailable
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted about 2 months ago. May 27, 2019 - 21:03 EDT
Investigating
OL2019 has been intermittently unavailable and we are investigating the issue.
Posted about 2 months ago. May 27, 2019 - 13:43 EDT
This incident affected: Email Previews (Outlook 2019 (Windows 10)).