Spam Tests - Outlook results not populating
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted Jan 26, 2016 - 07:50 EST
Investigating
We are investigating an issue that is preventing Outlook desktop spam results from populating. We are working to resolve as quickly as we can. Thanks!
Posted Jan 21, 2016 - 14:43 EST