Email Analytics Campaign Data - Slow Processing Times
Incident Report for Litmus
Resolved
Email Analytics is now processing campaign data at full speed. Thank you for your patience
Posted Mar 20, 2015 - 13:10 EDT
Investigating
We are aware of a situation where EA Campaign Data is slow to load. We are working on resolving the issue and getting all EA data up to date.
Posted Mar 20, 2015 - 08:50 EDT