Email Analytics Issues
Incident Report for Litmus
Resolved
All set! Thank you for your patience.
Posted 11 months ago. Dec 13, 2017 - 10:57 EST
Investigating
We are aware of an issue that is preventing users from accessing Email Analytics through the Litmus website. We are working on a fix and hope to have it back up shortly. Thanks!
Posted 11 months ago. Dec 13, 2017 - 10:32 EST