Email Previews clients experiencing performance issues
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted Feb 11, 2015 - 20:35 EST
Investigating
Some Email Previews clients are experiencing a period of performance related issues. We are aware of the issue and are working to quickly and properly resolve the incident.
Posted Feb 11, 2015 - 16:57 EST