Email Previews experiencing slowness
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted 13 days ago. Nov 09, 2017 - 12:47 EST
Monitoring
Our hosting provider has reached out to us and let us know they are aware of the issue. We are closely monitoring the situation and will update this page once the issue is resolved.

Thank you for your patience!
Posted 13 days ago. Nov 09, 2017 - 10:51 EST