Email Previews - Period of high failure rates
Incident Report for Litmus
Resolved
We have identified the issue and are up and running!

Thank you for your patience!
Posted Aug 05, 2015 - 12:01 EDT
Investigating
We are investigating an issue that is causing our email previews clients to fail tests.

We will update this page with any details we have along the way.

Thank you for your patience!
Posted Aug 05, 2015 - 10:17 EDT