Users may experience issues when trying to add users to their account
Incident Report for Litmus
Resolved
This incident has been resolved.
Posted 8 months ago. Sep 15, 2017 - 12:49 EDT
Investigating
We are aware of this issue and are currently working on a fix. Thank you!
Posted 8 months ago. Sep 15, 2017 - 10:58 EDT